The Geneious Interface

The Geneious main window has five important areas or 'panels'.

Interface

The Sources Panel

The Sources Panel displays your stored documents and contains the services Geneious Prime offers for storing and retrieving data. The arrow (>) symbol indicates that a folder contains sub-folders. Click this symbol to expand or contract folders.

Sources

The Sources Panel allows you to access:

  • Your Local Documents, including Deleted Items.

  • the Geneious Plasmid Features database

  • NCBI databases - Gene, Genome, Nucleotide, PopSet, Protein, Pubmed, SNP, Structure and Taxonomy.

  • Uniprot database (EMBL)

  • Shared databases, if set up.

You can view options for any selected service with the right mouse button, or by clicking the Options button at the bottom of the Sources Panel in Mac OS X.

For more information on managing folders in the Sources panel, see Organizing your local documents.

The Document Table

The Document Table displays summaries of each document in a selected folder or folders, presented in table form. A local folder may contain any mixture of documents, such as DNA sequences, protein sequences, journal articles, sequence alignments, and trees.

DocumentTable

The type of document is shown by the icon, as detailed below:

Icons

Selecting a document in the Document Table will display its details in the Document View Panel. Selecting multiple documents will show a view of all the selected documents if they are of similar types, e.g. selecting two sequences will show both of them in the sequence view.

The easiest way to select multiple documents is by clicking on the checkboxes down the left-hand side of the table. Standard keyboard controls can also be used (Shift and Ctrl/command click).

Above the Document Table you can optionally display a navigation bar which shows the folder path to whichever document or folder is currently selected. This is off by default but can be enabled by going to Tools → Preferences → Appearance and Behavior and checking Show folder path.

To view the functions available for any particular document or group of documents, right-click (Ctrl+click on Mac OS X) on a selection of them. These options vary depending on the type of document.

For information on how to search and filter documents in the Document Table, see Searching and filtering local documents.

Document Table features

Editing

Values can be typed into the columns of the table. This is a useful way of editing the information in a document. To edit a particular value, first click on the document and then click on the column which you want to edit. Enter the appropriate new information and press enter. Certain columns cannot be edited however, eg. the NCBI accession number.

Copying

Column values can be copied. This is a quick method of extracting searchable information such as an accession number. To copy a value, right-click (Ctrl+click on Mac OS X) on it, and choose the "Copy name" option, where name is the column name.

Sorting

All columns can be alphabetically, numerically or chronologically sorted, depending on the data type. To sort by a given column click on its header. If you have different types of documents in the same folder, click on the "Icon" column to sort then according to their type.

Export

The contents of the documents table can be exported in .csv or .tsv format, enabling you to export sequences and their statistics for a set of documents. For further information see Export to CSV or TSV files.

Managing Columns

You can reorder the columns to suit. Click on the column header and drag it to the desired horizontal position.

You can also choose which columns you want to be visible by right-clicking (Ctrl-click on Mac OS X) on any column header or by clicking the small header button above the top right corner of the table. This gives a popup menu with a list of all the available columns.

Manage Columns

Use the checkboxes to show or hide the columns you wish to display. Your preference is remembered so if you turn off a column it will remain hidden in all areas of the program until you show it again.

This menu also contains the following options to help you manage columns:

  • Lock Column Order locks the state of the columns in the current table so that Geneious will never modify the way the columns are set up. You can still change the columns yourself however.

  • Save Current State... allows you to save the the current state if the columns so you can easily apply it to other tables. You can give the state a name and it will then appear in the Load Column State... menu.

  • Load Column State... contains all of the columns states you have saved. Selecting a column state from here will immediately apply that state to the current table and lock the columns to maintain the new state. Use Delete Column State... to remove unwanted columns states from this menu.

Note. New columns can be added to the document table by adding Meta-Data to documents (see Metadata)

The Document Viewer Panel

The Document Viewer Panel shows the contents of any document clicked on in the Document Table, allowing you to view sequences, alignments, trees, 3D structures, journal article abstracts and other types of documents in a graphical or plain text view.

viewers

Options for controlling the look and layout of a given document are displayed in the right-hand panel. These options vary depending on what type of document you are viewing. For detailed information on specific types of viewers, please refer to the sections below:

To view large documents, you can open them in a new window by double clicking.

In the document viewer panel there are three tabs that are common to most types of documents: Text view, Lineage and Info.

Text view shows the document's information in text format. This tab is not available for pdf documents: instead the user needs to either click the View Document button or double-click to view it.

The Info tab contains the document Properties (including metadata) and History. For further details on the Lineage tab see Parent-Descendant Tracking.

General viewer controls

There are several general options which are available on all viewers, which are shown in the toolbar at the top right of the viewer. Some of these can also be accessed through the View menu.

splitHorizontal32 Split View: Provides several options for splitting the view so that multiple views are shown simultaneously for one document. When the view is split, selection of annotations and regions of the sequence are synchronized across the viewers. To close split views click the

button which is also on the right of the toolbar.

expandViewer32 Expand View: Expands the document view panel to fill the main window by hiding the sources panel on the right and the document table above. Clicking this again will return the layout to its original state.

newWindow32 New Window: Opens another view of the current document in a separate window. This allows you to have several documents open at once and gives more space for viewing. This can also be achieved by double clicking in the document table.

The Toolbar

The toolbar contains buttons that provide shortcuts to common functions in Geneious Prime, including BLAST, Workflows, Align/Assemble, Tree building, Primer Design and Cloning. The toolbar also provides shortcuts for Adding and Exporting files, and accessing the Help menu options.

The Back and Forward options help you move between previous views and are analogous to the back and forward buttons in a web browser. To go back and forward between folders you have recently accessed, use Shift-click.

The toolbar can be customized by right-clicking on it (CTRL-click on Windows/Linux, command-click on Mac OS X). This gives a popup menu with the following options:

Show Labels: Turns the text labels on or off.

Large Icons: Switches between large and small icons.

Customize: Lists all functions that can be added to the toolbar. Selecting/deselecting buttons will show/hide the buttons in the toolbar.

Toolbar

Toolbar shortcuts for a particular operation can also be added from within that operation's setup dialog. When the setup options for a particular operation are opened, click the settings cog in the bottom left of the window and choose Show toolbar shortcut to add a button to the toolbar for that option.

Status bar

Below the Toolbar, there is a grey status bar. This bar displays the status of the currently selected service. For example, when you are running a search, it displays the number of matches, and the time remaining for the search to finish.

The Help Panel

The Help Panel is off by default, and can be opened by clicking the Help icon in the toolbar and going to Quick Help. The Help Panel has a Help tab and a Tutorial tab.

Figure_TheHelpPanel

The Help tab provides you with information about the service you are currently using or the viewer you are currently viewing. The help displayed in the help tab changes as you click on different services and choose different viewers.

The Tutorial is aimed at first-time users of Geneious Prime. It is highly recommended that you work through the tutorial if you haven't used Geneious Prime before.

The Help panel can be closed at any time by clicking the button in its top corner, or by toggling the Quick Help option in the Help menu.